Friday, March 25, 2022
HomeApplecommunity - search_order of customized dns resolver isn't working

community – search_order of customized dns resolver isn’t working


macos 10.15.7

I’ve a neighborhood dns server working on my machine I need to resolve all requests for the “.localdev” area.

I created this file:

#/and so forth/resolver/localdev
area localdev
nameserver
search_order 1
timeout 5

I run scutil --dns and ensure I see this:

resolver #8
  area   : localdev
  timeout  : 5
  flags    : Request A information
  attain    : 0x00000000 (Not Reachable)
  order    : 1

I run nslookup towards my native dns server straight and ensure its working and returns the precise IP: nslookup derp.localdev <my dns servers ip>

However my default nameserver remains to be taking priority. After I run nslookup derp.localdev it goes to my default nameserver (on this case my wifi router). Similar once I browse to it by way of chrome.

Why is that this taking place. Is search_order being ignored? I would like to have the ability to browse to *.localdev hosts with my internet browser.

RELATED ARTICLES

LEAVE A REPLY

Please enter your comment!
Please enter your name here

Most Popular

Recent Comments